<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://themirrornewspaper.com/news/xmlrpc.php" />
<title>Obituaries: 08-13-20 &#8211; The Mirror Newspapers</title>
<!-- Optimized by SG Optimizer plugin version - 5.6.1 --><script>window._wca = window._wca || [];</script>
<link rel='dns-prefetch' href='//stats.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Mirror Newspapers &raquo; Feed" href="https://themirrornewspaper.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The Mirror Newspapers &raquo; Comments Feed" href="https://themirrornewspaper.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/themirrornewspaper.com\/news\/wp-includes\/js\/wp-emoji-release.min.js"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='tie-insta-style-css'  href='https://themirrornewspaper.com/news/wp-content/plugins/instanow/assets/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://themirrornewspaper.com/news/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wc-block-vendors-style-css'  href='https://themirrornewspaper.com/news/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/vendors-style.css' type='text/css' media='all' />
<link rel='stylesheet' id='wc-block-style-css'  href='https://themirrornewspaper.com/news/wp-content/plugins/woocommerce/packages/woocommerce-blocks/build/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='cptch_stylesheet-css'  href='https://themirrornewspaper.com/news/wp-content/plugins/captcha/css/front_end_style.css' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://themirrornewspaper.com/news/wp-includes/css/dashicons.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='cptch_desktop_style-css'  href='https://themirrornewspaper.com/news/wp-content/plugins/captcha/css/desktop_style.css' type='text/css' media='all' />
<link rel='stylesheet' id='taqyeem-buttons-style-css'  href='https://themirrornewspaper.com/news/wp-content/plugins/taqyeem-buttons/assets/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='taqyeem-style-css'  href='https://themirrornewspaper.com/news/wp-content/plugins/taqyeem/style.css' type='text/css' media='all' />
<style id='woocommerce-inline-inline-css' type='text/css'>
.woocommerce form .form-row .required { visibility: visible; }
</style>
<link rel='stylesheet' id='tie-style-css'  href='https://themirrornewspaper.com/news/wp-content/themes/sahifa/style.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-woocommerce-css'  href='https://themirrornewspaper.com/news/wp-content/themes/sahifa/css/woocommerce.css' type='text/css' media='all' />
<link rel='stylesheet' id='tie-ilightbox-skin-css'  href='https://themirrornewspaper.com/news/wp-content/themes/sahifa/css/ilightbox/dark-skin/skin.css' type='text/css' media='all' />
<link rel='stylesheet' id='Droid+Sans-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans%3Aregular%2C700' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://themirrornewspaper.com/news/wp-content/plugins/jetpack/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var tie_insta = {"ajaxurl":"https:\/\/themirrornewspaper.com\/news\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://themirrornewspaper.com/news/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://themirrornewspaper.com/news/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://themirrornewspaper.com/news/wp-content/plugins/taqyeem/js/tie.js'></script>
<script type='text/javascript' src='https://themirrornewspaper.com/news/wp-content/plugins/woocommerce/assets/js/jquery-blockui/jquery.blockUI.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"\/news\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/themirrornewspaper.com\/cart\/","is_cart":"","cart_redirect_after_add":"yes"};
/* ]]> */
</script>
<script type='text/javascript' src='https://themirrornewspaper.com/news/wp-content/plugins/woocommerce/assets/js/frontend/add-to-cart.min.js'></script>
<script type='text/javascript' src='https://themirrornewspaper.com/news/wp-content/plugins/js_composer/assets/js/vendors/woocommerce-add-to-cart.js'></script>
<script async defer type='text/javascript' src='https://stats.wp.com/s-202033.js'></script>
<link rel='https://api.w.org/' href='https://themirrornewspaper.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://themirrornewspaper.com/news/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://themirrornewspaper.com/news/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<meta name="generator" content="WooCommerce 4.3.1" />
<link rel="canonical" href="https://themirrornewspaper.com/obituaries/obituaries-08-13-20/" />
<link rel='shortlink' href='https://wp.me/P2JApF-1ON' />
<link rel="alternate" type="application/json+oembed" href="https://themirrornewspaper.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthemirrornewspaper.com%2Fobituaries%2Fobituaries-08-13-20%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://themirrornewspaper.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthemirrornewspaper.com%2Fobituaries%2Fobituaries-08-13-20%2F&#038;format=xml" />
<script type='text/javascript'>
/* <![CDATA[ */
var taqyeem = {"ajaxurl":"https://themirrornewspaper.com/news/wp-admin/admin-ajax.php" , "your_rating":"Your Rating:"};
/* ]]> */
</script>

<style type="text/css" media="screen">

</style>

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style><link rel="shortcut icon" href="https://themirrornewspaper.com/news/wp-content/uploads/2017/07/favicon.png" title="Favicon" />
<!--[if IE]>
<script type="text/javascript">jQuery(document).ready(function (){ jQuery(".menu-item").has("ul").children("a").attr("aria-haspopup", "true");});</script>
<![endif]-->
<!--[if lt IE 9]>
<script src="https://themirrornewspaper.com/news/wp-content/themes/sahifa/js/html5.js"></script>
<script src="https://themirrornewspaper.com/news/wp-content/themes/sahifa/js/selectivizr-min.js"></script>
<![endif]-->
<!--[if IE 9]>
<link rel="stylesheet" type="text/css" media="all" href="https://themirrornewspaper.com/news/wp-content/themes/sahifa/css/ie9.css" />
<![endif]-->
<!--[if IE 8]>
<link rel="stylesheet" type="text/css" media="all" href="https://themirrornewspaper.com/news/wp-content/themes/sahifa/css/ie8.css" />
<![endif]-->
<!--[if IE 7]>
<link rel="stylesheet" type="text/css" media="all" href="https://themirrornewspaper.com/news/wp-content/themes/sahifa/css/ie7.css" />
<![endif]-->


<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="apple-touch-icon-precomposed" sizes="144x144" href="https://themirrornewspaper.com/news/wp-content/uploads/2017/07/Retina.png" />
<link rel="apple-touch-icon-precomposed" sizes="120x120" href="https://themirrornewspaper.com/news/wp-content/uploads/2017/07/iPhone-Retina.png" />
<link rel="apple-touch-icon-precomposed" sizes="72x72" href="https://themirrornewspaper.com/news/wp-content/uploads/2017/07/iPad.png" />
<link rel="apple-touch-icon-precomposed" href="https://themirrornewspaper.com/news/wp-content/uploads/2017/07/iPhone.png" />



<style type="text/css" media="screen">

body{
	font-family: 'Droid Sans';
}

::-webkit-scrollbar {
	width: 8px;
	height:8px;
}


body{
					}
	
a {
	color: #293af5;
}
		
a:hover {
	color: #f56f08;
}
		
#theme-header {
	background-color:#000000 !important; 
	background-image: url('https://themirrornewspaper.com/news/wp-content/uploads/2017/01/header-back2.jpg') !important; 
	background-repeat:no-repeat !important; 
	background-attachment:fixed !important; 
	background-position:center top !important; 
}


</style>

		<script type="text/javascript">
			/* <![CDATA[ */
				var sf_position = '0';
				var sf_templates = "<a href=\"{search_url_escaped}\">View All Results<\/a>";
				var sf_input = '.search-live';
				jQuery(document).ready(function(){
					jQuery(sf_input).ajaxyLiveSearch({"expand":false,"searchUrl":"https:\/\/themirrornewspaper.com\/?s=%s","text":"Search","delay":500,"iwidth":180,"width":315,"ajaxUrl":"https:\/\/themirrornewspaper.com\/news\/wp-admin\/admin-ajax.php","rtl":0});
					jQuery(".live-search_ajaxy-selective-input").keyup(function() {
						var width = jQuery(this).val().length * 8;
						if(width < 50) {
							width = 50;
						}
						jQuery(this).width(width);
					});
					jQuery(".live-search_ajaxy-selective-search").click(function() {
						jQuery(this).find(".live-search_ajaxy-selective-input").focus();
					});
					jQuery(".live-search_ajaxy-selective-close").click(function() {
						jQuery(this).parent().remove();
					});
				});
			/* ]]> */
		</script>
			<noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript>
	<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://themirrornewspaper.com/news/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>
<body id="top" class="page-template-default page page-id-6993 page-parent page-child parent-pageid-63 theme-sahifa woocommerce-no-js lazy-enabled wpb-js-composer js-comp-ver-5.7 vc_responsive">

<div class="wrapper-outer">

	<div class="background-cover"></div>

	<aside id="slide-out">

			<div class="search-mobile">
			<form method="get" id="searchform-mobile" action="https://themirrornewspaper.com/">
				<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
				<input type="text" id="s-mobile" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
			</form>
		</div><!-- .search-mobile /-->
	
			<div class="social-icons">
		<a class="ttip-none" title="Facebook" href="https://www.facebook.com/themirrornewspapers" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/user/TheMirrorNewspaper" target="_blank"><i class="fa fa-youtube"></i></a>
			</div>

	
		<div id="mobile-menu" ></div>
	</aside><!-- #slide-out /-->

		<div id="wrapper" class="wide-layout">
		<div class="inner-wrapper">

		<header id="theme-header" class="theme-header full-logo">
						<div id="top-nav" class="top-nav">
				<div class="container">

							<span class="today-date">Friday , August 14 2020</span>
				<div class="top-menu"><ul id="menu-top" class="menu"><li id="menu-item-289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-289"><a href="https://themirrornewspaper.com/community-links/">Community Links</a></li>
<li id="menu-item-95" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-95"><a href="https://themirrornewspaper.com/announcement-form/">Send Announcement</a></li>
<li id="menu-item-330" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-330"><a href="http://themirrornewspaper.com/subscriptions/digital-subscription/">Digital Subscribers</a></li>
<li id="menu-item-465" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465"><a href="https://themirrornewspaper.com/check-out-this-weeks-coupons/">Coupons</a></li>
<li id="menu-item-282" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-282"><a href="https://themirrornewspaper.com/pick-up-a-copy-today/">Pick Up A Copy Today!</a></li>
</ul></div>
						<div class="search-block">
						<form method="get" id="searchform-header" action="https://themirrornewspaper.com/">
							<button class="search-button" type="submit" value="Search"><i class="fa fa-search"></i></button>
							<input class="search-live" type="text" id="s-header" name="s" title="Search" value="Search" onfocus="if (this.value == 'Search') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search';}"  />
						</form>
					</div><!-- .search-block /-->
			<div class="social-icons">
		<a class="ttip-none" title="Facebook" href="https://www.facebook.com/themirrornewspapers" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/user/TheMirrorNewspaper" target="_blank"><i class="fa fa-youtube"></i></a>
			</div>

	
	
				</div><!-- .container /-->
			</div><!-- .top-menu /-->
			
		<div class="header-content">

					<a id="slide-out-open" class="slide-out-open" href="#"><span></span></a>
		
			<div class="logo">
			<h2>								<a title="The Mirror Newspapers" href="https://themirrornewspaper.com/">
					<img src="https://themirrornewspaper.com/news/wp-content/uploads/2017/05/Logo_Header-2.png" alt="The Mirror Newspapers" width="627" height="117" /><strong>The Mirror Newspapers Reflecting Life Along The Maumee River</strong>
				</a>
			</h2>			</div><!-- .logo /-->
<script type="text/javascript">
jQuery(document).ready(function($) {
	var retina = window.devicePixelRatio > 1 ? true : false;
	if(retina) {
       	jQuery('#theme-header .logo img').attr('src',		'https://themirrornewspaper.com/news/wp-content/uploads/2017/05/Logo_Header-2.png');
       	jQuery('#theme-header .logo img').attr('width',		'627');
       	jQuery('#theme-header .logo img').attr('height',	'117');
	}
});
</script>
						<div class="clear"></div>

		</div>
													<nav id="main-nav" class="fixed-enabled">
				<div class="container">

				
					<div class="main-menu"><ul id="menu-main" class="menu"><li id="menu-item-29" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-29"><a href="https://themirrornewspaper.com/">Home</a></li>
<li id="menu-item-224" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-224"><a href="https://themirrornewspaper.com/category/news/">News</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-226" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-226"><a href="https://themirrornewspaper.com/category/news/maumee/">Maumee</a></li>
	<li id="menu-item-252" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-252"><a href="https://themirrornewspaper.com/category/news/anthony-wayne/">Anthony Wayne</a></li>
	<li id="menu-item-366" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-366"><a href="https://themirrornewspaper.com/category/news/family/">Family</a></li>
	<li id="menu-item-225" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-225"><a href="https://themirrornewspaper.com/category/news/business/">Business</a></li>
	<li id="menu-item-1140" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1140"><a href="https://themirrornewspaper.com/category/health-fitness/">Health &#038; Fitness</a></li>
</ul>
</li>
<li id="menu-item-232" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-232"><a href="https://themirrornewspaper.com/category/sports/">Sports</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-233" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-233"><a href="https://themirrornewspaper.com/category/sports/maumee-sports/">Maumee Sports</a></li>
	<li id="menu-item-237" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-237"><a href="https://themirrornewspaper.com/category/sports/a-w-sports/">A.W. Sports</a></li>
</ul>
</li>
<li id="menu-item-70" class="menu-item menu-item-type-taxonomy menu-item-object-category current-menu-ancestor menu-item-has-children menu-item-70"><a href="https://themirrornewspaper.com/category/uncategorized/">Features</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-76" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76"><a href="https://themirrornewspaper.com/health-care-issues/">Health Care Issues</a></li>
	<li id="menu-item-90" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-90"><a href="https://themirrornewspaper.com/senior-partner-issues/">Senior Partner Issues</a></li>
	<li id="menu-item-68" class="menu-item menu-item-type-post_type menu-item-object-page current-page-ancestor current-menu-ancestor current-menu-parent current-page-parent current_page_parent current_page_ancestor menu-item-has-children menu-item-68"><a href="https://themirrornewspaper.com/obituaries/">Obituaries</a>
	<ul class="sub-menu menu-sub-content">
		<li id="menu-item-6995" class="menu-item menu-item-type-post_type menu-item-object-page current-menu-item page_item page-item-6993 current_page_item menu-item-6995"><a href="https://themirrornewspaper.com/obituaries/obituaries-08-13-20/">Obituaries: 08-13-20</a></li>
		<li id="menu-item-6940" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6940"><a href="https://themirrornewspaper.com/obituaries/obituaries-08-13-20/obituaries-08-06-20/">Obituaries: 08-06-20</a></li>
		<li id="menu-item-6899" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6899"><a href="https://themirrornewspaper.com/obituaries/obituaries-08-13-20/obituaries-08-06-20/obituaries-07-30-20/">Obituaries: 07-30-20</a></li>
		<li id="menu-item-6866" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6866"><a href="https://themirrornewspaper.com/obituaries/obituaries-08-13-20/obituaries-08-06-20/obituaries-07-30-20/obituaries-07-23-20/">Obituaries: 07-23-20</a></li>
	</ul>
</li>
	<li id="menu-item-206" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-206"><a href="https://themirrornewspaper.com/letters-to-the-editor/">Letters To The Editor</a></li>
</ul>
</li>
<li id="menu-item-129" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-129"><a href="https://themirrornewspaper.com/calendar/">Event Calendars</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-135" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-135"><a href="https://themirrornewspaper.com/calendar/">Community Calendar</a></li>
	<li id="menu-item-133" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-133"><a href="https://themirrornewspaper.com/calendar/clubs/">Clubs</a></li>
	<li id="menu-item-801" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-801"><a href="https://themirrornewspaper.com/calendar/church-news/">Church News</a></li>
	<li id="menu-item-139" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-139"><a href="https://themirrornewspaper.com/calendar/health/">Health</a></li>
	<li id="menu-item-144" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-144"><a href="https://themirrornewspaper.com/calendar/140-2/">Education</a></li>
	<li id="menu-item-148" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-148"><a href="https://themirrornewspaper.com/calendar/walk-run/">Walk &#038; Run</a></li>
	<li id="menu-item-152" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152"><a href="https://themirrornewspaper.com/calendar/exhibits/">Exhibits</a></li>
	<li id="menu-item-160" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-160"><a href="https://themirrornewspaper.com/calendar/art-museum/">Art Museum</a></li>
	<li id="menu-item-156" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156"><a href="https://themirrornewspaper.com/calendar/history/">History</a></li>
	<li id="menu-item-166" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-166"><a href="https://themirrornewspaper.com/calendar/toledo-zoo/">Toledo Zoo</a></li>
	<li id="menu-item-170" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-170"><a href="https://themirrornewspaper.com/calendar/you-can-help/">You Can Help</a></li>
	<li id="menu-item-174" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-174"><a href="https://themirrornewspaper.com/calendar/kids/">Kids</a></li>
	<li id="menu-item-178" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-178"><a href="https://themirrornewspaper.com/calendar/reunions/">Reunions</a></li>
	<li id="menu-item-183" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-183"><a href="https://themirrornewspaper.com/calendar/pet-calendar/">Pet Calendar</a></li>
</ul>
</li>
<li id="menu-item-52" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-52"><a href="https://themirrornewspaper.com/classifieds/">Classifieds</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-6981" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6981"><a href="https://themirrornewspaper.com/classifieds/classifieds-08-13-20/">Classifieds: 08-13-20</a></li>
	<li id="menu-item-6935" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6935"><a href="https://themirrornewspaper.com/classifieds/classifieds-08-13-20/classifieds-08-06-20/">Classifieds: 08-06-20</a></li>
	<li id="menu-item-6894" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6894"><a href="https://themirrornewspaper.com/classifieds/classifieds-08-13-20/classifieds-08-06-20/classifieds-07-30-20/">Classifieds: 07-30-20</a></li>
	<li id="menu-item-6858" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6858"><a href="https://themirrornewspaper.com/classifieds/classifieds-08-13-20/classifieds-08-06-20/classifieds-07-30-20/classifieds-07-23-20/">Classifieds: 07-23-20</a></li>
</ul>
</li>
<li id="menu-item-53" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-53"><a href="http://mirrornews.photoreflect.com">View Photos</a></li>
<li id="menu-item-85" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-85"><a href="https://themirrornewspaper.com/subscriptions/">Subscriptions</a>
<ul class="sub-menu menu-sub-content">
	<li id="menu-item-86" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-86"><a href="https://themirrornewspaper.com/subscriptions/print-subscription/">Print Subscription</a></li>
	<li id="menu-item-87" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-87"><a href="https://themirrornewspaper.com/subscriptions/digital-subscription/">Digital Subscription</a></li>
</ul>
</li>
<li id="menu-item-115" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-115"><a href="https://themirrornewspaper.com/advertising/">Advertising</a></li>
<li id="menu-item-843" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-843"><a href="https://themirrornewspaper.com/online-store/">Online Store</a></li>
<li id="menu-item-2072" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2072"><a href="https://themirrornewspaper.com/contact-us/">Contact Us</a></li>
</ul></div>										<a href="https://themirrornewspaper.com/?tierand=1" class="random-article ttip" title="Random Article"><i class="fa fa-random"></i></a>
					
					
				</div>
			</nav><!-- .main-nav /-->
					</header><!-- #header /-->

	
	
	<div id="main-content" class="container full-width">



		
	
	<div class="content">

		
		<nav id="crumbs"><a href="https://themirrornewspaper.com/"><span class="fa fa-home" aria-hidden="true"></span> Home</a><span class="delimiter">/</span><a href="https://themirrornewspaper.com/obituaries/">Obituaries</a><span class="delimiter">/</span><span class="current">Obituaries: 08-13-20</span></nav><script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"BreadcrumbList","@id":"#Breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"name":"Home","@id":"https:\/\/themirrornewspaper.com\/"}},{"@type":"ListItem","position":2,"item":{"name":"Obituaries","@id":"https:\/\/themirrornewspaper.com\/obituaries\/"}}]}</script>
		

		
		<article class="post-listing post post-6993 page type-page status-publish " id="the-post">

			
			<div class="post-inner">

			
								<h1 class="name post-title entry-title">Obituaries: 08-13-20</span></h1>

				<p class="post-meta"></p>
				<div class="clear"></div>
			
				<div class="entry">
					
					<p><img data-attachment-id="6984" data-permalink="https://themirrornewspaper.com/obituaries/dcim100mediadji_0026-jpg/" data-orig-file="https://i0.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/Bernard.jpg?fit=100%2C136&amp;ssl=1" data-orig-size="100,136" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;2.2&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;FC220&quot;,&quot;caption&quot;:&quot;DCIM100MEDIADJI_0026.JPG&quot;,&quot;created_timestamp&quot;:&quot;1518885525&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;4.73&quot;,&quot;iso&quot;:&quot;100&quot;,&quot;shutter_speed&quot;:&quot;0.008647&quot;,&quot;title&quot;:&quot;DCIM100MEDIADJI_0026.JPG&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="DCIM100MEDIADJI_0026.JPG" data-image-description="" data-medium-file="https://i0.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/Bernard.jpg?fit=100%2C136&amp;ssl=1" data-large-file="https://i0.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/Bernard.jpg?fit=100%2C136&amp;ssl=1" class="alignleft wp-image-6984 size-full" src="https://i0.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/Bernard.jpg?resize=100%2C136&#038;ssl=1" alt="" width="100" height="136" data-recalc-dims="1" /></p>
<p style="text-align: justify;"><strong>Joshua Bernard</strong></p>
<p style="text-align: justify;">Joshua A. “Josh” Bernard, age 37, of Maumee, passed away on Tuesday, June 23.</p>
<p style="text-align: justify;">Josh was the Director of Information Technology for OBS Financial for 17 years. He loved technology from an early age, building his first computer at age 14. The owner of the computer store where he purchased the components was so impressed with his knowledge that he asked him to get a work permit and offered him a job. Josh devoted time late into the night learning advancements in technology to find better ways of doing things in order to help others. He also loved traveling, flying his drone, music and movies, but most of all spending time with his many friends and family and being “Uncle Pooh” to his friends’ little girls, whom he loved dearly.</p>
<p style="text-align: justify;">Preceded in death by his father, Jack Bernard; grandmother, Ellen Renaux; and cousin, Rogier Renaux, Jr.; Josh is survived by his mother, Cinda; brother, Chad; niece, Allison; uncle, Rogier (Barbara) Renaux; aunt, Karen Warren; and furbaby, Ripley. <span class="Apple-converted-space"> </span></p>
<p style="text-align: justify;">A celebration of Josh’s life will be held at a date yet to be determined, due to COVID concerns. Memorial tributes may be made to the Toledo Area Humane Society, Family House or a charity of the donor’s choice. Josh will be terribly missed, but always in our hearts.</p>
<div class="clear"></div><div style="margin-top:20px; margin-bottom:20px;" class="divider divider-solid"></div>
<p style="text-align: justify;"><strong><img data-attachment-id="6985" data-permalink="https://themirrornewspaper.com/obituaries/raepaul/" data-orig-file="https://i2.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/RaePaul.jpg?fit=100%2C130&amp;ssl=1" data-orig-size="100,130" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;1.8&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;iPhone 11&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1582641811&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;4.25&quot;,&quot;iso&quot;:&quot;500&quot;,&quot;shutter_speed&quot;:&quot;0.016666666666667&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="RaePaul" data-image-description="" data-medium-file="https://i2.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/RaePaul.jpg?fit=100%2C130&amp;ssl=1" data-large-file="https://i2.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/RaePaul.jpg?fit=100%2C130&amp;ssl=1" class="alignleft size-full wp-image-6985" src="https://i2.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/RaePaul.jpg?resize=100%2C130&#038;ssl=1" alt="" width="100" height="130" data-recalc-dims="1" />Rae Paul</strong></p>
<p style="text-align: justify;">“Her children arise and call her blessed; her husband also, and he praises her: Give her the reward she has earned, and let her works bring her praise at the city gate.” Proverbs 31</p>
<p style="text-align: justify;">On July 3, Rae Paul, the matriarch of the Paul family, passed peacefully into the loving arms of Jesus with her family holding her hands. <span class="Apple-converted-space"> </span></p>
<p style="text-align: justify;">She was born on October 30, 1929 in Monaville, W.Va., the second child of Mae and Warren Colley. Rae and her husband Danny lived in Maumee for 33 years, with all of their children graduating from Maumee High School. After her last child graduated, Rae worked for the Kelly’s IGA bakery and The Andersons bakery for 16 years. Rae and Danny moved in 1999 to Atlantic Beach, Fla., where their two daughters lived. Rae loved the sun and spent her last 20 years enjoying the beaches of Florida.</p>
<p style="text-align: justify;">Rae was a Christian woman.<span class="Apple-converted-space">  </span>She loved the Lord with all her heart and longed for the day when she would see Jesus face to face. She was a prayer warrior, and her endless prayers and constant petitions before the Father were a constant source of strength. She loved well, gave generously, forgave quickly and always extended mercy. Her example of what a godly woman should be was modeled daily for all who knew her. She was a lioness when it came to her family. Her strength, dignity and faithful instruction gave them a solid foundation on which they could build. Her children never doubted their mother’s unending love for them. She encouraged them to strive to meet their goals and achieve their dreams. And so, they did.</p>
<p style="text-align: justify;">Rae suffered tremendous loss in her later years. In addition to her parents, she was preceded in death by her husband, Danny; daughter, Linda Skeeles; sons, Danny Ray Paul and David Paul; and brother, Gerald Colley. Her faith in God and the amazing strength that came from that love helped her not only get through these difficult times but also gave her the fortitude to remain hopeful and joyful until the very end.</p>
<p style="text-align: justify;">She is survived by her son, Frank (Marcia) Paul; daughter, Michelle Paul; grandchildren, Chad Skeeles, Toni Skeeles-Jones, Rebecca Adamson, D.J. (Amy) Paul, Nathan (Rita) Paul, Adam (Grace) Burkett and Ashley Burkett; and great-grandchildren, Bryon Jones, Jr., Matthew Adamson, Caydence Adamson, Makayla Paul and Taylor Paul. Rae loved her nieces and nephews as her own and she is survived by her nephews, Jerry (Luann), John (Kelly) and Matt (Melissa) Colley; and nieces, Leah Emory, Anne (Jim) Domanowski, Tina (Randy) Kincaid, Jane Monroe, Jacqueline (Steve) Sorohan and Carol (Shad) Bucher. Rae was a faithful friend and is survived by many special friends from her church in Ohio and in Florida, especially her dear friends, Dessie Bishop and Susan Dyer.<span class="Apple-converted-space"> </span></p>
<p style="text-align: justify;">Rae will be laid to rest with her husband, Danny, at the Jacksonville National Cemetery in Jacksonville, Fla. A celebration of her life will take place at a later date. The family asked that any memorials be made to a ministry that was near to Rae’s heart, Embracing His Call Ministries, 2602-30 Isabella Blvd., Jacksonville Beach, FL 32250. Please visit the online tribute at <a href="http://quinn-shalz.com" target="_blank" rel="noopener noreferrer">quinn-shalz.com</a>.<span class="Apple-converted-space"> </span></p>
<div class="clear"></div><div style="margin-top:20px; margin-bottom:20px;" class="divider divider-solid"></div>
<p style="text-align: justify;"><strong><img data-attachment-id="6986" data-permalink="https://themirrornewspaper.com/obituaries/dodds/" data-orig-file="https://i1.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/Dodds.jpg?fit=100%2C140&amp;ssl=1" data-orig-size="100,140" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;1.7&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;moto z4&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1596199543&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;4.745&quot;,&quot;iso&quot;:&quot;375&quot;,&quot;shutter_speed&quot;:&quot;0.016666666666667&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Dodds" data-image-description="" data-medium-file="https://i1.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/Dodds.jpg?fit=100%2C140&amp;ssl=1" data-large-file="https://i1.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/Dodds.jpg?fit=100%2C140&amp;ssl=1" class="alignleft size-full wp-image-6986" src="https://i1.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/Dodds.jpg?resize=100%2C140&#038;ssl=1" alt="" width="100" height="140" data-recalc-dims="1" />Leanna Dodds</strong></p>
<p style="text-align: justify;">Leanna Arline (Williams) Dodds, age 83, of Waterville, made her journey to Our Father on Friday, July 31.</p>
<p style="text-align: justify;">Born in Auglaize County, Ohio on May 17, 1937, she married Gary, her husband of 65 years, on December 30, 1955. She graduated from Kenton High School in 1955 and worked for the Kenton Times newspaper. She moved on to The Anthony Wayne Standard in Waterville as chief editor, from there to the Northwest Signal in Napoleon and finished her career in real estate for Reiser Realty. Leanna’s first love in life was her family – children, grandchildren and the added blessing of being able to enjoy her great-grandchildren. With a competitive spirit, she enjoyed tennis and pickle ball and cards with friends and family. She and her husband had circles of dear friends that spanned from Ohio to Michigan and into Florida.</p>
<p style="text-align: justify;">Leanna was preceded in death by her parents, Cleta Naomi Myers and Luther Williams; stepfather, Charles Myers; and brothers, Hank (Merlin), Luther, Daniel, Jim and Dwain. Surviving are her husband, Gary; sister, Monad Faye; children, Cheri (Steve) Saneholtz and Tracy (Neil) Mock; grandchildren, Tyler (Melissa) Saneholtz, Joseph (Chelsea) Saneholtz, Adam (Katelyn) Mock and Alexandria Mock; and seven great-grandchildren.</p>
<p style="text-align: justify;">A private funeral service took place at Walker Mortuary in Napoleon, followed by interment in Glenwood Cemetery in Napoleon, due to the pandemic. A celebration of life ceremony will be announced at a later time. Memorial contributions may be made to St. Jude Children’s Hospital.</p>
<div class="clear"></div><div style="margin-top:20px; margin-bottom:20px;" class="divider divider-solid"></div>
<p style="text-align: justify;"><strong><img data-attachment-id="6987" data-permalink="https://themirrornewspaper.com/obituaries/morris/" data-orig-file="https://i0.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/Morris.jpg?fit=100%2C138&amp;ssl=1" data-orig-size="100,138" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Morris" data-image-description="" data-medium-file="https://i0.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/Morris.jpg?fit=100%2C138&amp;ssl=1" data-large-file="https://i0.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/Morris.jpg?fit=100%2C138&amp;ssl=1" class="alignleft size-full wp-image-6987" src="https://i0.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/Morris.jpg?resize=100%2C138&#038;ssl=1" alt="" width="100" height="138" data-recalc-dims="1" />Merub Morris</strong></p>
<p style="text-align: justify;">Merub Adell Morris, age 73, of Maumee, passed away on Tuesday, August 4.</p>
<p style="text-align: justify;">Born on December 5, 1946 to John and Bernice (Leasman) Morris in San Diego, Calif., she was employed at Swanton Healthcare. She enjoyed painting, spending time with her dogs, baking, visits with her McDonald’s friends in Maumee and long conversations on the phone with friends. Merub was a member of the New Apostolic Church in Fremont.</p>
<p style="text-align: justify;">Preceded in death by her parents, she is survived by her sister, Mary Ann (Ted) Reed, and many cousins.</p>
<p style="text-align: justify;">Family and friends will be received from 5:00 until 8:00 p.m. on Friday, August 14 at the Maison-Dardenne-Walker Funeral Home in Maumee, where funeral services will be conducted at 11:00 a.m. on Saturday, August 15.</p>
<div class="clear"></div><div style="margin-top:20px; margin-bottom:20px;" class="divider divider-solid"></div>
<p style="text-align: justify;"><strong>Sara Satterthwaite</strong></p>
<p style="text-align: justify;">Sara Irene Satterthwaite, age 41, of Maumee, passed away on Wednesday, August 5.</p>
<p style="text-align: justify;">Born on December 26, 1978 to David and Ann Marie (Nortz) Satterthwaite, she was raised and cared for by her parents for 20 years and due to her disabilities became a resident at Sunshine Communities. Sara had a secure and active life and was a fighter with her medical issues. Her presence and smile brought joy to family, friends, staff and volunteers at both home and Sunshine. She loved water, sunshine, music and horseback riding. She was happy to help others by donating her organs. She will be dearly missed but is reunited with her brother, Sean, as they begin their next journey together.<span class="Apple-converted-space"> </span></p>
<p style="text-align: justify;">In addition to her parents, Sara is survived by her sister, Liz Satterthwaite; and nieces, Sophia Rose and Phoebe Elizabeth. She was preceded in death by her grandparents; brother, Sean Satterthwaite; and uncle, Tom.<span class="Apple-converted-space"> </span></p>
<p style="text-align: justify;">Services will be announced at a later date. Memorial contributions may be made to the Sunshine Communities or in the care of Ann Marie Satterthwaite for a scholarship fund for Sara’s nieces, Sophia Rose and Phoebe Elizabeth.<span class="Apple-converted-space"> </span></p>
<div class="clear"></div><div style="margin-top:20px; margin-bottom:20px;" class="divider divider-solid"></div>
<p style="text-align: justify;"><strong>Madonna Brenner</strong></p>
<p style="text-align: justify;">Madonna Anna Brenner, age 95, of Stryker, passed away on Friday, August 7.</p>
<p style="text-align: justify;">Born on March 8, 1925 in Defiance County to the late Edward and Irene (Batt) Schindler, she graduated from Ney High School in 1943. On June 5, 1946, she married Lawrence “Larry” Brenner, who preceded her in death in 2017. Prior to her retirement, she worked as a chiropractic assistant at the Williams Clinic. Madonna was a member of St. Patrick’s Catholic Church in Bryan and a former member of the Stryker Gardening Club. She loved flowers of all shapes, sizes and colors. She was known for sharing her black raspberries and her redbud trees and new saplings.</p>
<p style="text-align: justify;">Surviving are her daughter, Linda (Raymond) Hertel, of Antwerp; daughter, Mary (James) Burns, of Maumee; grandchildren, Troy and Chad (Debra) Everhart and Catherine, Sean, Marybeth and Maggie Burns; great-grandchildren, Jaden, Gavin and Carson Everhart; sisters, Marybelle Timbrook, Janice Neiling and Jean Ewers; brother, Cletus Schindler; and sister-in-law, Patsy Schindler. She was preceded in death by her parents; husband, Larry; son, William Brenner; sister, Bernadette Sheets; brothers, Richard, Francis and Robert Schindler; and infant sister, Armella.</p>
<p style="text-align: justify;">Due to the pandemic, all services will be private. A funeral Mass will be offered at St. Patrick’s Catholic Church in Bryan with Fr. Andrew Wellmann officiating. Memorial contributions may be made to the Defiance Inpatient Hospice Center or St. Patrick’s Catholic Church.<span class="Apple-converted-space"> </span></p>
<div class="clear"></div><div style="margin-top:20px; margin-bottom:20px;" class="divider divider-solid"></div>
<p style="text-align: justify;"><strong><img data-attachment-id="6988" data-permalink="https://themirrornewspaper.com/obituaries/schohl/" data-orig-file="https://i2.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/Schohl.jpg?fit=100%2C132&amp;ssl=1" data-orig-size="100,132" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Schohl" data-image-description="" data-medium-file="https://i2.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/Schohl.jpg?fit=100%2C132&amp;ssl=1" data-large-file="https://i2.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/Schohl.jpg?fit=100%2C132&amp;ssl=1" class="alignleft size-full wp-image-6988" src="https://i2.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/Schohl.jpg?resize=100%2C132&#038;ssl=1" alt="" width="100" height="132" data-recalc-dims="1" />Georgette Schohl</strong></p>
<p style="text-align: justify;">Georgette A. Schohl, age 100, formerly of Maumee, passed away on Friday, August 7.</p>
<p style="text-align: justify;">Born on March 29, 1920 in Parkersburg, W.Va., to George and Blanche (Maison) Wittebort, she was a longtime employee at the Food Town headquarters in Maumee. Her first husband, James Hertzfeld, was killed in the service during World War II in November 1944. Her second husband, Paul Schohl, preceded her in death in August 1992. Georgette was most proud of her four sons. Known for her dry wit and sense of humor, when her boys told her to quit worrying, she told them, “When you read this, you’ll know I quit worrying.” She was truly devoted to her family and liked to know they were all healthy and safe and together as much as possible. Georgette also really enjoyed cooking for all of her family. <span class="Apple-converted-space"> </span></p>
<p style="text-align: justify;">Preceded in death by her parents; husbands; sister, Rose Sonner; brother, Robert Wittebort; and granddaughter, Kristin Hertzfeld, Georgette is survived by her sons, Thomas (Gloria) Hertzfeld, Robert (Mary) Hertzfeld, Michael Hertzfeld and John (Bridget) Schohl; 10 grandchildren; and nine great-grandchildren. <span class="Apple-converted-space"> </span></p>
<p style="text-align: justify;">Funeral services will be private with interment in St. Joseph Catholic Cemetery in Maumee. Memorial contributions may be made to the Wounded Warriors Project.</p>
<div class="clear"></div><div style="margin-top:20px; margin-bottom:20px;" class="divider divider-solid"></div>
<p style="text-align: justify;"><strong><img data-attachment-id="6989" data-permalink="https://themirrornewspaper.com/obituaries/fuller/" data-orig-file="https://i0.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/Fuller.jpg?fit=100%2C122&amp;ssl=1" data-orig-size="100,122" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;1321713774&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;1&quot;}" data-image-title="Fuller" data-image-description="" data-medium-file="https://i0.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/Fuller.jpg?fit=100%2C122&amp;ssl=1" data-large-file="https://i0.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/Fuller.jpg?fit=100%2C122&amp;ssl=1" class="alignleft size-full wp-image-6989" src="https://i0.wp.com/themirrornewspaper.com/news/wp-content/uploads/2020/08/Fuller.jpg?resize=100%2C122&#038;ssl=1" alt="" width="100" height="122" data-recalc-dims="1" />Eugene Fuller</strong></p>
<p style="text-align: justify;">Eugene “Shorty” Fuller, age 91, passed away on Saturday, August 8.</p>
<p style="text-align: justify;">Born on February 15, 1929 to Walter and Elsie (Clark) Fuller, he graduated from DeVilbiss High School in 1947 and in 1950 he married Juanita Huddleston; they were able to enjoy 43 years together before her passing in 1993. After having twin girls in 1952, Shorty enlisted in the U.S. Army and served from 1954-56. During his pre-service days, he worked as a mechanic and a racecar driver, racing under the name of Shorty Mitchell. Entrepreneurship took hold, and Shorty became the owner of multiple body shops, truck stops, Fuller’s Marina, the Byrnegate Lounge and the Kold Keg Restaurant.</p>
<p style="text-align: justify;">His interests were many. He was a member and past commodore of the Maumee River Yacht Club, member of Harborview Yacht Club, member and past president of the MRYC Blue Gavel and member of the Maumee Elks, Maumee Eagles and American Legion. Shorty enjoyed boating, NASCAR, puzzles and golfing (which he played into his 90s). He loved his “Chick Mobile,” a Mazda Miata convertible, and for his 80th birthday, he bought himself a Harley Davidson motorcycle. At MRYC he would sponsor cocktail parties on his boat for his “Shorty’s Angels.”</p>
<p style="text-align: justify;">In addition to his parents, he was preceded in death by his wife, Juanita; stepmother, Jeanette Fuller; and sons-in-law, Fred Doriot and Pete Kramp. Surviving are his daughters, Karin Doriot and Sharon Kramp; grandchildren, Jody Dohanos and Kurt Kramp; sisters, Jan Osterhout, Bev (Stan) Mylek and Barb (Butch) Rode; and great-grandsons, Derek, Dylan, and Devon.</p>
<p style="text-align: justify;">Family and friends will be received beginning at 10:00 a.m. on Thursday, August 13 at the Maison-Dardenne-Walker Funeral Home in Maumee, followed by a Blue Gavel and funeral service at 11:00 a.m. Masks will be required. Due to the limited number of people allowed by the cemetery, interment will be private. In lieu of flowers, memorial contributions may be made to the Maumee United Methodist Church Mission Fund or the Toledo Humane Society.</p>
<p style="text-align: justify;"><div class="box shadow  alignleft"><div class="box-inner-block"><i class="fa tie-shortcode-boxicon"></i>
			<strong>If you&#8217;d like to send us an obituary notice, <a href="https://themirrornewspaper.com/news/contact-us/" class="shortc-button small orange ">Contact Us</a> Photos can also be attached. </strong>Or send email directly to: <a href="mailto:info@themirrornewspaper.com">info@themirrornewspaper.com</a> <strong>Cost is $50.00</strong> and can be made over the phone by calling (419) 893-8135.
			</div></div>
					
									</div><!-- .entry /-->

								<div class="clear"></div>
			</div><!-- .post-inner -->

			
		</article><!-- .post-listing -->
		
		
				
<div id="comments">


<div class="clear"></div>


</div><!-- #comments -->
	</div><!-- .content -->




<aside id="sidebar">
	<div class="theiaStickySidebar">
	</div><!-- .theiaStickySidebar /-->
</aside><!-- #sidebar /-->	<div class="clear"></div>
</div><!-- .container /-->

<footer id="theme-footer">
	<div id="footer-widget-area" class="footer-3c">

			<div id="footer-first" class="footer-widgets-box">
						<div id="text-html-widget-4" class="text-html-box" style="text-align:center;">
			<p style="text-align: center;"><img class="aligncenter size-full wp-image-352" src="https://themirrornewspaper.com/news/wp-content/uploads/2017/05/footer-logo.png" alt="" width="300" height="153" /></p>
<p style="text-align: center;"><span style="color: #ffffff;"><strong><span style="font-family: helvetica, arial, sans-serif;">113 W. Wayne St., Maumee, Ohio 43537
</span></strong></span></p>
<p style="text-align: center;"><span style="color: #ffffff;"> <span style="font-family: helvetica, arial, sans-serif;">Ph:</span><strong><span style="font-family: helvetica, arial, sans-serif;"> (419) 893-8135 • </span></strong><span style="font-family: helvetica, arial, sans-serif;">Fax:</span><strong><span style="font-family: helvetica, arial, sans-serif;"> (419) 893-6397</span></strong></span></p>
			</div>
				</div>
	
			<div id="footer-second" class="footer-widgets-box">
			<div id="nav_menu-2" class="footer-widget widget_nav_menu"><div class="footer-widget-top"><h4>Popular Links</h4></div>
						<div class="footer-widget-container"><div class="menu-top-container"><ul id="menu-top-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-289"><a href="https://themirrornewspaper.com/community-links/">Community Links</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-95"><a href="https://themirrornewspaper.com/announcement-form/">Send Announcement</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-330"><a href="http://themirrornewspaper.com/subscriptions/digital-subscription/">Digital Subscribers</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-465"><a href="https://themirrornewspaper.com/check-out-this-weeks-coupons/">Coupons</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-282"><a href="https://themirrornewspaper.com/pick-up-a-copy-today/">Pick Up A Copy Today!</a></li>
</ul></div></div></div><!-- .widget /-->		</div><!-- #second .widget-area -->
	

			<div id="footer-third" class="footer-widgets-box">
			<div id="facebook-widget-3" class="footer-widget facebook-widget"><div class="footer-widget-top"><h4>Find us on Facebook		</h4></div>
						<div class="footer-widget-container">			<div class="facebook-box">
				<iframe src="https://www.facebook.com/plugins/likebox.php?href=https://www.facebook.com/themirrornewspapers&amp;width=300&amp;height=250&amp;show_faces=true&amp;header=false&amp;stream=false&amp;show_border=false" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:300px; height:250px;" allowTransparency="true"></iframe>
			</div>
	</div></div><!-- .widget /-->		</div><!-- #third .widget-area -->
	
		
	</div><!-- #footer-widget-area -->
	<div class="clear"></div>
</footer><!-- .Footer /-->
				
<div class="clear"></div>
<div class="footer-bottom">
	<div class="container">
		<div class="alignright">
			"Reflecting Life Along The Maumee River Since 1980"		</div>
				<div class="social-icons">
		<a class="ttip-none" title="Facebook" href="https://www.facebook.com/themirrornewspapers" target="_blank"><i class="fa fa-facebook"></i></a><a class="ttip-none" title="Youtube" href="https://www.youtube.com/user/TheMirrorNewspaper" target="_blank"><i class="fa fa-youtube"></i></a>
			</div>

		
		<div class="alignleft">
			© 2020 Mirror Publishing Co., Inc. | All Rights Reserved. | <a href="http://www.lawrencegraphics.com" target="_blank" rel="noopener">LG</a>		</div>
		<div class="clear"></div>
	</div><!-- .Container -->
</div><!-- .Footer bottom -->

</div><!-- .inner-Wrapper -->
</div><!-- #Wrapper -->
</div><!-- .Wrapper-outer -->
	<div id="topcontrol" class="fa fa-angle-up" title="Scroll To Top"></div>
<div id="fb-root"></div>
	<script type="text/javascript">
		var c = document.body.className;
		c = c.replace(/woocommerce-no-js/, 'woocommerce-js');
		document.body.className = c;
	</script>
	<script type='text/javascript' src='https://themirrornewspaper.com/news/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript' src='https://themirrornewspaper.com/news/wp-content/plugins/woocommerce/assets/js/js-cookie/js.cookie.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/news\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
/* ]]> */
</script>
<script type='text/javascript' src='https://themirrornewspaper.com/news/wp-content/plugins/woocommerce/assets/js/frontend/woocommerce.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/news\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_9b893ca44a504153d49e90ba58adaf79","fragment_name":"wc_fragments_9b893ca44a504153d49e90ba58adaf79","request_timeout":"5000"};
/* ]]> */
</script>
<script type='text/javascript' src='https://themirrornewspaper.com/news/wp-content/plugins/woocommerce/assets/js/frontend/cart-fragments.min.js'></script>
<script type='text/javascript'>
		jQuery( 'body' ).bind( 'wc_fragments_refreshed', function() {
			var jetpackLazyImagesLoadEvent;
			try {
				jetpackLazyImagesLoadEvent = new Event( 'jetpack-lazy-images-load', {
					bubbles: true,
					cancelable: true
				} );
			} catch ( e ) {
				jetpackLazyImagesLoadEvent = document.createEvent( 'Event' )
				jetpackLazyImagesLoadEvent.initEvent( 'jetpack-lazy-images-load', true, true );
			}
			jQuery( 'body' ).get( 0 ).dispatchEvent( jetpackLazyImagesLoadEvent );
		} );
	
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var tie = {"mobile_menu_active":"true","mobile_menu_top":"","lightbox_all":"true","lightbox_gallery":"true","woocommerce_lightbox":"","lightbox_skin":"dark","lightbox_thumb":"vertical","lightbox_arrows":"","sticky_sidebar":"1","is_singular":"1","reading_indicator":"","lang_no_results":"No Results","lang_results_found":"Results Found"};
/* ]]> */
</script>
<script type='text/javascript' src='https://themirrornewspaper.com/news/wp-content/themes/sahifa/js/tie-scripts.js'></script>
<script type='text/javascript' src='https://themirrornewspaper.com/news/wp-content/themes/sahifa/js/ilightbox.packed.js'></script>
<script type='text/javascript' src='https://themirrornewspaper.com/news/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://themirrornewspaper.com/news/wp-content/themes/sahifa/js/search.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/themirrornewspaper.com\/news\/wp-admin\/admin-ajax.php","nonce":"30d68c73d8","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/themirrornewspaper.com\/news\/wp-login.php?redirect_to=https%3A%2F%2Fthemirrornewspaper.com%2Fobituaries%2Fobituaries-08-13-20%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://themirrornewspaper.com/news/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202033.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.7.1',blog:'40417407',post:'6993',tz:'-4',srv:'themirrornewspaper.com'} ]);
	_stq.push([ 'clickTrackerInit', '40417407', '6993' ]);
</script>
</body>
</html>